Power outage at the Columbus, OH campus
Incident Report for ODW Logistics
Resolved
Power restored at the Columbus, OH campus. Total downtime 2 hr 5 min.
Posted about 2 years ago. Jul 14, 2015 - 16:38 EDT
Identified
At 2:25pm EST the Columbus, OH campus has lost power due to severe storms passing through the area. All corporate systems are currently operating on generated power.
Posted about 2 years ago. Jul 14, 2015 - 14:51 EDT